Gutenberg est arrivé – êtes-vous prêt?

##MT##Gutenberg est arrivé – êtes-vous prêt?#/MT##

 

 

WordPress 5.0 est officiellement sorti depuis jeudi après de nombreux retards et faux départs. Êtes-vous prêt pour ce nouvel éditeur ? Réponse courte : probablement pas.

 

Un nouvel éditeur WYSIWYG de WordPress

WordPress 5.0 remplace l’ancien éditeur de texte natif par son nouvel éditeur  » What You See Is What You Get  » appelé Gutenberg en référence à l’inventeur de l’imprimerie. Il permet aux utilisateurs de créer des blocs de contenu pour les images, le texte, les vidéos et une foule d’autres éléments. À première vue, cela semble génial puisque presque tous les autres CMS modernes offrent cette fonctionnalité. C’est certainement un pas dans la bonne direction pour WordPress. Ils se sont toujours vantés d’être une plateforme qui s’adresse à la fois aux développeurs et aux éditeurs de contenu, mais l’éditeur de texte standard n’a jamais été vraiment suffisant pour quelqu’un sans expérience de codage. Gutenberg promet de rationaliser ce processus pour les non-développeurs qui créent des sites Web.

Cependant, cette mise à jour n’est pas sans défauts. Si vous consultez le GitHub de WordPress, il y a actuellement 285 bugs au moment d’écrire ces lignes et près de 1400 problèmes au total ! Comme pour toute version majeure, les bugs abondent, mais Matt Mullenweg rapporte que la version 5.0 est encore suffisamment stable pour une sortie officielle. En plus des bugs qui ont déjà été signalés, une refonte de l’éditeur lui-même risque de causer des problèmes sur votre site Web. Selon que vous avez ou non un modèle personnalisé, un plugin utilisé pour l’édition tel que Visual Composer, et la façon dont votre contenu est disposé sur vos pages, cela affectera la transition vers Gutenberg.

 

Le plugin Classic Editor ne va pas disparaître de sitôt

Il y a cependant de bonnes nouvelles ici. WordPress a déjà publié l’éditeur classique, qui peut être installé avant de passer à la version 5.0. Ce plugin maintiendra non seulement l’éditeur classique que nous connaissons et aimons tous, mais il cachera également les références à la fois à Gutenberg et à sa mise à jour. La meilleure partie de l’éditeur classique est qu’il sera pris en charge jusqu’en 2022, de sorte que vous n’aurez pas à vous soucier de Gutenberg jusque-là. Avec la fonctionnalité permettant de cacher les références à Gutenberg, vous n’aurez pas à vous inquiéter que quelqu’un d’autre qui pourrait utiliser votre site l’active et provoque le chaos sur votre site.

Si vous décidez d’essayer Gutenberg, il est fortement recommandé de créer une sauvegarde complète de votre site et de tester la compatibilité dans un environnement de démonstration de votre site. Une fois que vous avez conclu que Gutenberg est compatible avec tous vos plugins et fonctionnalités de thème, vous pouvez vous sentir quelque peu en sécurité en essayant de faire une mise à niveau. Selon toute vraisemblance, les thèmes et les plugins qui s’appuyaient sur l’éditeur classique, ne fonctionneront probablement pas si bien que cela avec Gutenberg.

Donc, avant de mettre à jour vers WordPress 5.0, assurez-vous d’installer le plugin de l’éditeur classique ou vous passerez par défaut à Gutenberg, ce qui a le potentiel de faire des ravages sur les modèles personnalisés et certains plugins qui n’ont pas été mis à jour en temps opportun. En plus de cela, comme beaucoup de mises à jour de WordPress, il est probable qu’il y ait quelques bugs qui traînent, alors peut-être qu’attendre jusqu’à ce qu’il soit un peu plus stable serait une bonne idée. 

Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn